75 lines
2.3 KiB
Nix
75 lines
2.3 KiB
Nix
{
|
|
description = "marked dots";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
|
|
zen-browser = {
|
|
url = "github:0xc000022070/zen-browser-flake";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
lanzaboote = {
|
|
url = "github:nix-community/lanzaboote/v0.4.2";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
stylix.url = "github:danth/stylix";
|
|
};
|
|
|
|
outputs = { nixpkgs, lanzaboote, ... } @ inputs: let
|
|
system = "x86_64-linux";
|
|
host = "swordfish";
|
|
profile = "nvidia-laptop";
|
|
username = "marked";
|
|
enableLanzaboote = true;
|
|
in {
|
|
nixosConfigurations = {
|
|
nvidia = nixpkgs.lib.nixosSystem {
|
|
inherit system;
|
|
specialArgs = {
|
|
inherit inputs;
|
|
inherit username;
|
|
inherit host;
|
|
inherit profile;
|
|
};
|
|
modules = [ ./profiles/nvidia ] ++ (if enableLanzaboote == true then [ lanzaboote.nixosModules.lanzaboote ./bootloaders/lanzaboote ] else [ ./bootloaders/systemd ]);
|
|
};
|
|
nvidia-laptop = nixpkgs.lib.nixosSystem {
|
|
inherit system;
|
|
specialArgs = {
|
|
inherit inputs;
|
|
inherit username;
|
|
inherit host;
|
|
inherit profile;
|
|
};
|
|
modules = [ ./profiles/nvidia-laptop ] ++ (if enableLanzaboote == true then [ lanzaboote.nixosModules.lanzaboote ./bootloaders/lanzaboote ] else [ ./bootloaders/systemd ]);
|
|
};
|
|
intel = nixpkgs.lib.nixosSystem {
|
|
inherit system;
|
|
specialArgs = {
|
|
inherit inputs;
|
|
inherit username;
|
|
inherit host;
|
|
inherit profile;
|
|
};
|
|
modules = [ ./profiles/intel ] ++ (if enableLanzaboote == true then [ lanzaboote.nixosModules.lanzaboote ./bootloaders/lanzaboote ] else [ ./bootloaders/systemd ]);
|
|
};
|
|
amd = nixpkgs.lib.nixosSystem {
|
|
inherit system;
|
|
specialArgs = {
|
|
inherit inputs;
|
|
inherit username;
|
|
inherit host;
|
|
inherit profile;
|
|
};
|
|
modules = [ ./profiles/amd ] ++ (if enableLanzaboote == true then [ lanzaboote.nixosModules.lanzaboote ./bootloaders/lanzaboote ] else [ ./bootloaders/systemd ]);
|
|
};
|
|
};
|
|
};
|
|
}
|